What's new

2021 Coolant issue

Leggs

New member
Joined
Sep 17, 2021
Messages
9
Reaction score
2
Points
3
Location
Klamath Falls Or
Hello everyone, Was wondering if anyone had experienced this or had a suggestion. Have a 2021 trail boss with the 5.3 engine. After running a few errands, I parked the truck in the garage, Came out about a hour later and had a small creek under the rig. When I had shut it off, I could still hear something running under the hood which I assume was the A.C. unit but didn't think much of it. I know when you turn off the truck sometimes you will get a small amount of water from the A.C but as you can see by the pictures (and this is just what made it out of the garage) that we are talking about a substantial amount of water. Anyone have an idea what may have caused this? Truck has been running fine and I have had no other issues with it. Thanks
 

Attachments

  • IMG_0045.jpg
    IMG_0045.jpg
    350.1 KB · Views: 73
  • IMG_0044.jpg
    IMG_0044.jpg
    325.5 KB · Views: 31
Mine definitely drips water after AC has been running, more than you’d think at times. Even stopped a few times to dip my finger in it to make sure it’s water.

Big puddle looks like it could have a sheen on it, have you climbed under truck to see if anything else is leaking?
 
Mine definitely drips water after AC has been running, more than you’d think at times. Even stopped a few times to dip my finger in it to make sure it’s water.

Big puddle looks like it could have a sheen on it, have you climbed under truck to see if anything else is leaking?
Went out this morning to check the coolant level which shows it is fine. Did not start the truck Went back out and have another big puddle on the garage floor. It was dry earlier. Its either water or coolant as I gave it a little taste, but I don't see anything dripping. Just don't know where that much water could come from when the coolant level shows its right to the fill level line.
 

Attachments

  • IMG_0048.jpg
    IMG_0048.jpg
    444.7 KB · Views: 31
  • IMG_0047.jpg
    IMG_0047.jpg
    230 KB · Views: 32
  • IMG_0049.jpg
    IMG_0049.jpg
    563.9 KB · Views: 30
Went out this morning to check the coolant level which shows it is fine. Did not start the truck Went back out and have another big puddle on the garage floor. It was dry earlier. Its either water or coolant as I gave it a little taste, but I don't see anything dripping. Just don't know where that much water could come from when the coolant level shows its right to the fill level line.
Oh and also I have the on-star diagnostic app and it shows no issues with the truck.
 
Went out this morning to check the coolant level which shows it is fine. Did not start the truck Went back out and have another big puddle on the garage floor. It was dry earlier. Its either water or coolant as I gave it a little taste, but I don't see anything dripping. Just don't know where that much water could come from when the coolant level shows its right to the fill level line.
Update, went back out and did a closer inspection on the fluid. There is definitely oil mixed in. quite a bit on the right side of the truck. Thoughts? Transmission cooler maybe? Service center is 80 miles away. Not thinking this should be driven.
 

Attachments

  • IMG_0050.jpg
    IMG_0050.jpg
    408.9 KB · Views: 20
Update, went back out and did a closer inspection on the fluid. There is definitely oil mixed in. quite a bit on the right side of the truck. Thoughts? Transmission cooler maybe? Service center is 80 miles away. Not thinking this should be driven.
Maybe a blown head gasket?
 
Haven't seen / heard about anything like this at all with the 2019+ Silverados. I'd contact your dealer and tell/show him what you have and hopefully they pay for the tow. Hope it works out and keep us posted.
 
Update, went back out and did a closer inspection on the fluid. There is definitely oil mixed in. quite a bit on the right side of the truck. Thoughts? Transmission cooler maybe? Service center is 80 miles away. Not thinking this should be driven.
I’ve searched and can’t seem to find anything matching the issue, especially on that new of a truck. Maybe others with more mechanical knowledge can help troubleshoot. You didn’t mention what engine oil looks like/level. Noticed any white smoke on start up?
Pretty sure the other liquid is coolant? Or just AC water mixed with oil leak?
I too would trailer it to a dealer, assuming you’re still under warranty, either 3/36k or 5/100k, and have them take a look.
 
I’ve searched and can’t seem to find anything matching the issue, especially on that new of a truck. Maybe others with more mechanical knowledge can help troubleshoot. You didn’t mention what engine oil looks like/level. Noticed any white smoke on start up?
Pretty sure the other liquid is coolant? Or just AC water mixed with oil leak?
I too would trailer it to a dealer, assuming you’re still under warranty, either 3/36k or 5/100k, and have them take a look.
Thanks for the post's Pistols and JMZVET. Engine oil level is fine and is not black like what's on the paper towel. No white smoke on startup and the truck seems to run just fine. Truck only has 11,000 miles on it and the oil has been changed twice already. Have a call into the dealership so we will see what they have to say. Thanks again
 
Are you able to get under the truck, on your back, and look around with a flash light? That’s a lot of liquid coming from somewhere.
 
Update, went back out and did a closer inspection on the fluid. There is definitely oil mixed in. quite a bit on the right side of the truck. Thoughts? Transmission cooler maybe? Service center is 80 miles away. Not thinking this should be driven.
I was worried for you when I first saw this image, but looking closer it looks like a wet napkin with dirt. You have no observed oil leak, no observed coolant leak, and the napkin looks like dirty water to me. I wouldn't worry about it, especially if you cant find any leaks on the underbody of the vehicle.

If it was a transmission leak, the fluid would have a red tint to it.
 
I was worried for you when I first saw this image, but looking closer it looks like a wet napkin with dirt. You have no observed oil leak, no observed coolant leak, and the napkin looks like dirty water to me. I wouldn't worry about it, especially if you cant find any leaks on the underbody of the vehicle.

If it was a transmission leak, the fluid would have a red tint to it.
Yea could be dirt. So I got ahold of service and sent those pictures over and they said it was normal and to take it out and drive it . Did that for about 20 minutes, Ten with A.C on and 10 with heater. Parked it and not one drop of liquid has come out. Got under the truck and do not see any evidence of a leak. Truck runs fine and I have no alerts coming up on the dash. Maybe that is normal but I have never seen that much water come out of a rig like that just from the A.C. I will keep a eye on it and if anything comes up I will post it on here. Thanks for all the replies.. This is a good forum.
 

Most Reactions

Back
Top