What's new

Infotainment Issues

Ryan 65

New member
Joined
Sep 30, 2020
Messages
8
Reaction score
0
Points
1
My 2020 Trailboss is a great truck and I get compliments every where I go but I'm having my second issue with the Infotainment system. I had issues before and it was all replaced and now at 37000 miles it is acting up again. No HD radio and no volume upon initial startup until you make several station switches. What gives??
 
no sure what the problem is but mine just started doing the volume thing. volume wont work some times upon start up. i have to push the power button on the radio a few times for it to work.

also, some times when i use the volume controls behind the steering wheel the volume bar on the dash will stay stuck blocking the MPH.
i have to push the volume button up and down a bunch of times until the bar moves and then disappears. pretty annoying.
 
I had a one time issue where I used controls on wheel to increase volume and it went to maximum loudness and I could not turn it down at all finally was able to turn it down with knob but it kept going up by itself. Almost pulled over to turn off truck and restart.

I’m also having an issue with saving favorite radio stations. If I preset a station and change it, the next day it’s back to the old one but if I put the station number in manually then that station will show up as saved. Very strange.
 
Having an issue after 3 months of owning the truck. The volume will toggle up and down, accordingly, using the controls on the steering wheel. However, on my radio, if I use the dial on the outside of the power button, the volume will go up, but it will no longer go down.

Known issue?
Solution?

Update: I pulled off the plastic volume knob and, consequentially, the Home button to its left. I then placed it back in. This seemed to solve the issue, but then it happened again. Reapplied the above fix. It would work. Then it stopped. Reapplied. Eventually, this trick didn't work any longer. At first, I thought it was a hardware issue. Now I wonder if it is a software issue with sensitivity settings.
 
Last edited:
My 2020 Trailboss is a great truck and I get compliments every where I go but I'm having my second issue with the Infotainment system. I had issues before and it was all replaced and now at 37000 miles it is acting up again. No HD radio and no volume upon initial startup until you make several station switches. What gives??
I hate to think this way but are you sure they really replaced it. Sometimes I think these shops say they're going to replace or fix something and they really don't.
 

Most Reactions

Back
Top