What's new

New guy here!

Waterlefe1994

New member
Joined
Mar 18, 2024
Messages
4
Reaction score
1
Points
3
Location
Brighton michigan
Hi everyone! Loving my new to me trailboss so far just a couple things I have concerns about.
I have a 2021 trailboss with the 6.2 sitting at roughly 46,000 miles.

The ten speed has Been shifting a little rough lately. It also has hesitation taking off at stop signs. And sometimes after shifting into drive I can hear a loud bang when getting gas and stuff. Also there is a loud whining noise going up hills.

The other problem is there is a heavy ticking noise when turning on that is pretty bad. As it warms up it gets quieter but is still there. I’ve read on the lifter tick and I’m hoping it’s not the case.

I plan on going into the dealer in a couple weeks but I’m unsure of what I need to bring up and ask the service advisor.

Thanks for any help!
 
Welcome to the Forum. Your truck's problems are difficult to diagnose without being there and hearing the various noises.
Maybe the "bang" while accelerating is a broken motor mount? I'm sure some others will chime in with some help.
 
Welcome to the Forum. Your truck's problems are difficult to diagnose without being there and hearing the various noises.
Maybe the "bang" while accelerating is a broken motor mount? I'm sure some others will chime in with some help.
Thanks for the reply!
 
Hard to say what to do first. It appears you bought it used which doesn't help your concerns. Like Jmzvet stated without hearing the issue or looking at possible failure codes, just hard to diagnose. Good luck and let us know what they say. Guessing some warranty.......
 
Hard to say what to do first. It appears you bought it used which doesn't help your concerns. Like Jmzvet stated without hearing the issue or looking at possible failure codes, just hard to diagnose. Good luck and let us know what they say. Guessing some warranty.......
Yeah I mean it’s still got the power train warranty so I’m not too concerned for right now. I will definitely post once I can make it up to the dealer. Thanks!
 
Hard to say what to do first. It appears you bought it used which doesn't help your concerns. Like Jmzvet stated without hearing the issue or looking at possible failure codes, just hard to diagnose. Good luck and let us know what they say. Guessing some warranty.......
Yeah I mean it’s still got the power train warranty so I’m not too concerned for right now. I will definitely post once I can make it up to the dealer. Thanks
 

Most Reactions

Latest Discussions...

Back
Top