What's new

S&B CAI Hesitation/bogging

Rgirk4

New member
Joined
Feb 22, 2022
Messages
2
Reaction score
0
Points
1
Location
Arizona
I recently installed an S&B CAI on my 2020 silverado 1500 5.3L V8 trail boss. Ive had it in for about 2 weeks now with no issues. Suddenly I have noticed that when on the highway in the 72-75mph range with rpms sitting around 1600-2000rpm I get a slight "bog or hesitation" that you can hear and feel. Its not major but the rpms do dip and its almost like you let off the gas. Ive done research on what the cause is from the MAF sensor to cylinders misfiring, system getting too much air etc. I don’t have any check engine light or anything like that. Have only noticed this when I installed the CAI which makes me think it has something to do with the intake, but wanted to post here before taking it out and re installing the stock intake. I also recently cleaned the MAF sensor and still having the issue. Any suggestions?
 

Attachments

  • 30307106-FB40-4634-A7AF-55D5C8B61055.jpeg
    30307106-FB40-4634-A7AF-55D5C8B61055.jpeg
    285.7 KB · Views: 15

Spyderwebb

Member
Joined
Jul 8, 2020
Messages
53
Reaction score
39
Points
18
Make sure all your clamps along the intake assembly are tight, no air leaks. They need to be retightened after initial assembly! Might be something worth looking at?
 
OP
OP
R

Rgirk4

New member
Joined
Feb 22, 2022
Messages
2
Reaction score
0
Points
1
Location
Arizona
Make sure all your clamps along the intake assembly are tight, no air leaks. They need to be retightened after initial assembly! Might be something worth looking at?
I will triple check again make sure all clamps are as tight as possible. If not will have to put back in the stock box and see if that stops the issue. Thanks for the suggestion!
 

Spyderwebb

Member
Joined
Jul 8, 2020
Messages
53
Reaction score
39
Points
18
I will triple check again make sure all clamps are as tight as possible. If not will have to put back in the stock box and see if that stops the issue. Thanks for the suggestion!
I ran an S&B on my old 2010 Camaro, good intake. Have a Rotofab on the TB, no problems. You might also consider reaching out to S&B direct for suggestions!
 

CP72

New member
Joined
May 31, 2021
Messages
26
Reaction score
14
Points
3
Location
Oklahoma
I have an S&B on my 2020 5.3 for 6 months. No problems. Love it. Hope you get to the bottom of it. I agree, call S&B. Stock intake sucks!
 
Top