What's new

Tips for uneven tips…exhaust bezels

Neededarealtruck

New member
Joined
Feb 15, 2022
Messages
10
Reaction score
10
Points
3
Location
Northern USA
I had black ones installed and they didn’t go well with bumper and black out emblems. It was a flat primer style so I took them off and put the chrome back on.

I can’t for the life of me get them flush/true whatever you want to call it with the rear bumper.

The right side has given me more issues than the left.

Any tips? Does tightening sequence matter? Maybe I’m just OCD.
 

DylanVK

New member
Joined
Feb 11, 2022
Messages
11
Reaction score
3
Points
3
Location
Colorado
Not really even sure how they could get out of alignment since they're tab bolted to mounting points. Did something get bent taking them out/putting them back in?
 
OP
OP
N

Neededarealtruck

New member
Joined
Feb 15, 2022
Messages
10
Reaction score
10
Points
3
Location
Northern USA
Not really even sure how they could get out of alignment since they're tab bolted to mounting points. Did something get bent taking them out/putting them back in?
I don’t think so but anything’s possible. The dealership put the black ones on and gave me the chrome ones back.

I’ll get some pictures tomorrow.

I noticed on both sides one tab position is a touch higher than the other.

No one will ever notice but me, still kind of irritating.
 

JMac

New member
Joined
Dec 21, 2021
Messages
12
Reaction score
0
Points
1
Location
NJ
I have the same issue on the right side.
 
Joined
Jun 30, 2021
Messages
32
Reaction score
10
Points
8
Location
New York
I had the same issue when I changed mine out. I loosened all and then retightened. Don’t fully tighten one at a time.
 

PHXPHOTOG

Active member
Joined
May 22, 2021
Messages
139
Reaction score
123
Points
43
Location
PHX, AZ
It's the weak clips, they suck. I bought powder coated red ones off ebay. When I installed I noticed all of the clips did not seem to be mounted exactly the same. Sure enough mine don't sit aligned ether.
 

Latest Discussions...

Top