What's new

Any warranty issues yet??

tbuss5831

Member
Joined
Nov 17, 2020
Messages
40
Reaction score
15
Points
8
No, no parking brake sensors. I was told mine was part of a transfer harness issue. Not sure what the issue was with it but once it faulted out it triggered the engine derate, parking brake service and ESC service. The shop pulled the codes and ordered the part. The part took a month to get in. Then after that, dropped truck off to get fixed, was told a 4hr fix. 22 days later I got my truck back.
Parts guy ordered the part only, didnt know that it required one time use bolts, so that took another 2 weeks to get in, then the new part they put in faulted out again with a transmission temp sensor. Another week and a half the shop finally called that it's done.
Yep sounds about right. It was the strikes years ago that started the part shortage and then Covid hit. We cant get parts, it sucks but this is the reality we live in now. Going to be years till everything gets back to normal.
 

JonSnow

Member
Joined
Nov 1, 2020
Messages
34
Reaction score
20
Points
8
I have had my Trailboss for 5 months now and must say I totally love it!!!! I get compliments everywhere I go. Just the other day my infotainment screen totally quit working. The backup cam still works. I have a appointment at the dealership next week for its first oil change and to have this issue looked at.
Mine was doing that but only when my cell phone was paired. Consistently when paired I had the problem,unpair it,no problem. Seems adding the phone is too much for the system.🙄
Haven't seen any water leaks from rear window.
 

Typhoon

New member
Joined
May 22, 2021
Messages
4
Reaction score
2
Points
3
Location
California
My truck was in the service dept for appx 3wks for the same concern. Water leak at passenger side back glass. Eventually required entire back glass assy to be replaced. Very annoying
Yep washing my truck today and found the leak...same area too. Disappointing.
 

Jmzvet

Active member
Joined
Dec 27, 2020
Messages
173
Reaction score
74
Points
28
Location
San Diego CA
Yep washing my truck today and found the leak...same area too. Disappointing.
Where is the leak area? Any photos?
Does this affect all 2019-21 Silverados or does the power rear slider cause it?
 

Spyderwebb

Member
Joined
Jul 8, 2020
Messages
42
Reaction score
28
Points
18
The dealership tried the required seal job on my back window leak first, that didn't work. A few weeks later they installed a new rear glass, that did the job! In and out in one day because I made sure they had the glass in stock before scheduling the work. Happy to report they did a good job and no other damage or screw-ups (interior or exterior) from either repair!
 

Typhoon

New member
Joined
May 22, 2021
Messages
4
Reaction score
2
Points
3
Location
California
Where is the leak area? Any photos?
Does this affect all 2019-21 Silverados or does the power rear slider cause it?
No idea where exactly but it's somewhere by that black piece
 

Attachments

  • Screenshot_20210525-171112_Gallery.jpg
    Screenshot_20210525-171112_Gallery.jpg
    191.9 KB · Views: 87

NHNightskyTrailBoss

New member
Joined
May 26, 2021
Messages
17
Reaction score
5
Points
3
Location
Hooksett, NH
I had 2 Rams before my Trail Boss. Trust me,your a lot better off. Endless recalls and problems with my Rams.

I really hope you’re right. I had my 2016 for 77k miles with minimal issues outside of my ability. One was coincidentally a leaking rear window. Though I have no idea how much worse it could be had I purchased a new 5th Gen Ram. I really love the Trail Boss and hope it will continue to stay that way.
 

JonSnow

Member
Joined
Nov 1, 2020
Messages
34
Reaction score
20
Points
8
I really hope you’re right. I had my 2016 for 77k miles with minimal issues outside of my ability. One was coincidentally a leaking rear window. Though I have no idea how much worse it could be had I purchased a new 5th Gen Ram. I really love the Trail Boss and hope it will continue to stay that way.
My 2009 had the clutch pack go out in the rear diff and bad hemi tick. My 2014 2500 had 7 recalls and still had 4 when I traded it in. My 2020 Trail Boss LT has had zero issues except for a info screen issue due to phone pairing.
 

HeavyP

New member
Joined
Jun 4, 2021
Messages
3
Reaction score
0
Points
1
Location
Connecticut
Ok Up until today things were going good for my 2021 boss. I was on the highway heading to work when all of a sudden it seemed like my parking brake tried to engage. Instantly, I recieved:
Engine power reduced
Service ESC
Service parking brake.
As I pulled to the side of the road, the truck felt as if I was driving thru the parking brake alittle. Not sure if it was due to the "engine power reduced" issue.
So once parked on the side of the road, I engaged and disengaged the park brake with no issue. Shut the truck down for a couple minutes then restarted it back up. Check engine light stayed on but all other warnings were gone. Truck had power again so off to work I went.
Aside from this, the only issue I've had with the truck has been if I'm in 4 wheel drive and parked, I switch to 2 wheel drive and the park brake engages. Mentioned this to the dealer/shop and they hadn't heard of it.
Anyone else having or had this happen?
No, no parking brake sensors. I was told mine was part of a transfer harness issue. Not sure what the issue was with it but once it faulted out it triggered the engine derate, parking brake service and ESC service. The shop pulled the codes and ordered the part. The part took a month to get in. Then after that, dropped truck off to get fixed, was told a 4hr fix. 22 days later I got my truck back.
Parts guy ordered the part only, didnt know that it required one time use bolts, so that took another 2 weeks to get in, then the new part they put in faulted out again with a transmission temp sensor. Another week and a half the shop finally called that it's done.
10 days ago, check engine light comes on. Truck driving fine. So I head to dealership. A mile from dealership, I get service parking brake message, traction control off, and it goes into limp mode. 5400 miles on it. Whole dash lit up like a Christmas tree.

I pull it into the service bay, put it in park and shut it off, but the truck isn’t recognizing it’s in park, so it won’t let the key turn all the way to the off position.

they got the key out by disconnecting the battery and they pushed it into the shop, but as of right now it is throwing almost every code current, and they have no idea wtf is going on with it.
 

Attachments

  • 418F89C2-A3FE-4A87-A3AF-9B00CC1D7496.jpeg
    418F89C2-A3FE-4A87-A3AF-9B00CC1D7496.jpeg
    323.3 KB · Views: 16

HeavyP

New member
Joined
Jun 4, 2021
Messages
3
Reaction score
0
Points
1
Location
Connecticut
10 days ago, check engine light comes on. Truck driving fine. So I head to dealership. A mile from dealership, I get service parking brake message, traction control off, and it goes into limp mode. 5400 miles on it. Whole dash lit up like a Christmas tree.

I pull it into the service bay, put it in park and shut it off, but the truck isn’t recognizing it’s in park, so it won’t let the key turn all the way to the off position.

they got the key out by disconnecting the battery and they pushed it into the shop, but as of right now it is throwing almost every code current, and they have no idea wtf is going on with it.
2021
 
Top