What's new

Pulsar LT

JDenham

Member
Joined
Mar 13, 2021
Messages
48
Reaction score
13
Points
8
Location
Texas
I uninstalled my Pulsar LT. They never got back to me about the TPS monitor problem and also noticed it was causing problem with Bluetooth. After uninstall, al problems went away. Back to normal.
To bad, it would be a great adon if it worked correctly.
That’s weird issue with Bluetooth? What was it doing
 

overdriv

New member
Joined
Oct 11, 2021
Messages
11
Reaction score
1
Points
3
Location
Central IL
That’s weird issue with Bluetooth? What was it doing
Well, I posted to soon, without thinking it through. There was/is nothing wrong with my TPSM. I have a tire gauge that reads 35PSI regardless what is actually in the tire. I's gone now and the one I use now matches what the TPSs read.
Damn I'm sorry for posting these problems without a thorough troubleshoot. And now I don't think the bluetooth problems are related to the Pulsar. I haven't figured it out yet but I don't think it's the Pulsar.
I have the Pulsar LT installed again and everything seems ok. Still problems with Pandora over blue tooth, but after having similar problems while driving my Camaro yesterday, makes me think it's pandora and NOT the Pulsar.
Again, very sorry for the post claiming problems with the Pulsar LT, I have deleted both post so no one else will read them.
 

JDenham

Member
Joined
Mar 13, 2021
Messages
48
Reaction score
13
Points
8
Location
Texas
Well, I posted to soon, without thinking it through. There was/is nothing wrong with my TPSM. I have a tire gauge that reads 35PSI regardless what is actually in the tire. I's gone now and the one I use now matches what the TPSs read.
Damn I'm sorry for posting these problems without a thorough troubleshoot. And now I don't think the bluetooth problems are related to the Pulsar. I haven't figured it out yet but I don't think it's the Pulsar.
I have the Pulsar LT installed again and everything seems ok. Still problems with Pandora over blue tooth, but after having similar problems while driving my Camaro yesterday, makes me think it's pandora and NOT the Pulsar.
Again, very sorry for the post claiming problems with the Pulsar LT, I have deleted both post so no one else will read them.
Ya it’s gotta be Pandora App issue. Try deleting the App and re-installing it ? And see what it does
 

RocketIIITurbo

New member
Joined
Aug 9, 2021
Messages
18
Reaction score
4
Points
3
Location
Shenandoah Valley
I just updated my Pulsar software to fix the speed limiter problem. So far so good.. Check engine light came on after the update. - LOL I cleared it with the Pulsar and it hasn't returned. While the Pulsar will leave no traces if you remove it before going to the dealer, note that it will prevent OnStar from running diagnostics on your vehicle. On demand diagnostics as well as the diagnostic scan in your monthly OnStar vehicle report will fail.
 

JDenham

Member
Joined
Mar 13, 2021
Messages
48
Reaction score
13
Points
8
Location
Texas
I just updated my Pulsar software to fix the speed limiter problem. So far so good.. Check engine light came on after the update. - LOL I cleared it with the Pulsar and it hasn't returned. While the Pulsar will leave no traces if you remove it before going to the dealer, note that it will prevent OnStar from running diagnostics on your vehicle. On demand diagnostics as well as the diagnostic scan in your monthly OnStar vehicle report will fail.
Yup I had the same thing happen when I updated the Pulsar Software. Clear the ECM and it’s fine. Computer picks up communication errors when software updated. But no issues.
 

EricKim

New member
Joined
Nov 28, 2021
Messages
4
Reaction score
0
Points
1
Location
Texas
Speedo set at 140, Throttle Position at 2 or 3, disabled DFM (mine didn't come with Auto-Stop), and the whole reason for the Pulsar LT was the sounds that emitted "choppy" helicopter noise. During the 1st week of purchase on the TB with the 6.2L motor, I've elected to apply aFe Apollo GT Muffler Delete + $40 welding. Prior to this, I'd been using the L mode on 9 and noticed better-sounding exhaust notes (but this gets old every time I turn on the truck). My suggestion is to purchase the Pulsar LT if you are planning exhaust modifications, lift, or tire size changes in the future.
 

JDenham

Member
Joined
Mar 13, 2021
Messages
48
Reaction score
13
Points
8
Location
Texas
Speedo set at 140, Throttle Position at 2 or 3, disabled DFM (mine didn't come with Auto-Stop), and the whole reason for the Pulsar LT was the sounds that emitted "choppy" helicopter noise. During the 1st week of purchase on the TB with the 6.2L motor, I've elected to apply aFe Apollo GT Muffler Delete + $40 welding. Prior to this, I'd been using the L mode on 9 and noticed better-sounding exhaust notes (but this gets old every time I turn on the truck). My suggestion is to purchase the Pulsar LT if you are planning exhaust modifications, lift, or tire size changes in the future.
How does it sound with the muffler delete ? I was on the fence with the Muffler Delete vs Borla Atak crate muffler. I went with the Borla Crate Muffler and it’s pretty loud and slight drone at highway speeds
 
Joined
Mar 25, 2022
Messages
44
Reaction score
13
Points
8
Location
PA
I have a 2021 Trailboss with the 6.2. I added the Pulsar LT and like the functionality but have removed as there was an issue with it affecting the remote diagnostics. The myChevrolet app could not connect and remote start function thru app was hit or miss. I opened ticket with range technology last year and they have yet to supply fix. Last update, after I inquired, was March 18th “No resolution as of yet”. Wondering if anyone else is experiencing the same issues.
 

RocketIIITurbo

New member
Joined
Aug 9, 2021
Messages
18
Reaction score
4
Points
3
Location
Shenandoah Valley
I have a 2021 Trailboss with the 6.2. I added the Pulsar LT and like the functionality but have removed as there was an issue with it affecting the remote diagnostics. The myChevrolet app could not connect and remote start function thru app was hit or miss. I opened ticket with range technology last year and they have yet to supply fix. Last update, after I inquired, was March 18th “No resolution as of yet”. Wondering if anyone else is experiencing the same issues.
 

RocketIIITurbo

New member
Joined
Aug 9, 2021
Messages
18
Reaction score
4
Points
3
Location
Shenandoah Valley
That is one downside to pulsar. To me, unleashing the 6.2 is worth the inconvenience. It connects to the ECM path and there is no way around it. I remove it if I bring the truck in for service or call OnStar
 
Top